Error connecting to database: enpoint is temporary unavailable

I started the app not to long ago.

Worked fine for some time. Than it started throwing errors, when connecting to the database.

The same is also shown connecting from DataGrip

DBMS: PostgreSQL (no ver.)
Case sensitivity: plain=mixed, delimited=exact
[XX000] ERROR: Console request failed: endpoint is temporary unavailable. check your quotas and/or contact our support.

Hi @ggmueller

I just looked at your account, and the reason you are seeing this message is that you reached the data transfer limit included with the free database.

You can upgrade your database service to a bigger instance size to go over this limitation.

How do I see which data transfer limits are in place. All limits I can see in admin, seem to be ok.

Also, where do I find pricing on the data transfer?

Just another short update. For comparison I also tried Neon DB for the database.

If I understand correctly, free plan on Koyeb includes 1 GB of data. We triggered data transfer limits after about 3 days on a very idle running system.

I tried to reproduce it on Neon. After about 7 days I have about 120 MB of data transfer.

Could there be an issue regarding the way data transfer is counted?
Or does Koyeb aggregate different data.


Could you tell us more about the difference between your two configurations/settings?

From our internal investigation, what is reported by Neon matches what is stored in our database. If you’ll allow it, I could share some screenshots (with sensible information redacted) to eliminate this lead with your investigation.


What I did was to use the koyeb service that I had already deployed. Then switch it over to a Neon database. So same version of the software, same behaviour expected

So maybe my problem is that I do not understand the koyeb data transfer limit.

Please feel free to share some screenshots of the data you collected.


This was the usage displayed on Neon console for your database:

As you can see, this database has a data transfer that is near 1GiB.

From the Neon API, this was the information returned for your database:

And this is what we store on our side:


As you can see, we use the same value for data_transfer_bytes.

By any chance, do you execute any kind of operations on your database by the path used for/by your service health check?

Thanks for providing the data.
Not sure why it is different here and on my own instance on Neon.

Maybe it was just an unfortunate glitch.