What is the cause of this error?

ERROR: failed to determine the run command to launch your application: add a run command in your Service configuration or create a procfile in your git repository.

Hi @haeju-min,
This error is typically caused by locating project files in a sub-directory. In this case, you should modify the build and run commands in advanced settings or provide a work directory.

If that’s not the case, please provide the name of your app and service so that we can investigate it.

app and service name : plandly

Since December 17, 2023, the same error has been persistently occurring.

I haven’t made any changes to the build-related settings.
What could be the issue

Your service is running using the version from 2023-12-17.
Please check the changes made in your repository on 2023-12-18 when it stopped working.

You can try adding a run command in the service settings.

I tried reverting to version 2023-12-17 and running it again, but I still get the same error.
I don’t know the cause.