Create App not linking organization repo

I tried to create my first app from a repo under an organization I’m part of. The organization owner granted access to Koyeb for the repo, however, Koyeb is still not importing the project. Please let me know if I missed something.

Hi :wave:

I looked at your organization and it seems that the GitHub app is not installed.

Can you confirm the app is properly installed? If so, could you try to reinstalling it?


Hi Edouard
Thank you for the response. PFA a screenshot of the organization and repo I meant. I had requested access to only the required repo under the organization.

Hi @edouard
is there anything that I can do from my side to get this working?

Hey @Sebastian_James,

Have you tried to uninstall and reinstall the app to see if it solves the problem?

Hi @edouard
I tried uninstalling and reinstalling the app, but that didn’t solve the issue.

Hi @Sebastian_James,

I see that the app is not installed now. You have to install it yourself not the owner of the organization.
When you install it, please let me know and I will debug further.

Hi @Lukasz_Oles
Thank you for your response.
The owner of the GitHub organization, VePay, is Gichina. Since, Koyeb’s basic plan allows only 1 member, I’m checking with Gichina so he can create a Koyeb account and deploy.
I’ll keep you updated.

No no, I mean that you should install the app, if you have rights to access the repo you will be able to deploy it using your account.

No need for organization owner to do it.

I do have access rights to the repo. However, when I click update access I get

This action must be performed by an organization owner

PFA a screenshot of the same.

What happens when you click “Only selected repositories” ?

When I click, I get vepay-ai repo. That’s how I proceeded.

An update: I was permitted as Organization owner and now I’m able to deploy the app.
Thank you so much for the support. :innocent:

1 Like