502 Service unavailable with healthy service

I have been doing a project with Go and Gin Gonic, and the app was working fine. Upon a simple push to Github the service redeployed itself and all the health checks passed but the requests on my frontend started failing. Upon checking, the service started giving to all requests the 502 unavailable error from Koyeb, and none of the requests are reaching the API.

The code changed on the commits did not change any configuration that would interfere with this.

1 Like

Hi @Mark_Albrand,

Do you still have this problem, or has it resolved itself? If it’s resolved, how long was this happening?


It didn’t resolve. For a moment the service came back but 2 hours later the same thing happened again. In that time no change was made to the repo nor the service. We were in a hurry and needed the service functioning ASAP.

We tried changing it from the free instance to a paid one and that worked, but being forced to do that doesn’t seem quite right with us. I mean we understand that it’s a free service, but it literally stopped us from using it.

It should work just fine on the Free instance. Could you share service id? I will take a closer look.