Trouble connecting to socketIO service added to my app

Good day, I have been having an issue adding a socketIO server service to my current app.
I am running Sveltekit on port 8000 which points to /
but when I tried adding a new socketIO server running on port 3000 which points to /ws I cannot seem to connect correctly to the socketIO server.
SocketIO looks like it expects to be running in the root / so it gave me an error that the ws is a namespace.I currently started up a new app for the socketIO server but that will not work in production because I have comply with some strict one origin rules for the one client.
So I can use different ports on the same domain.Has anyone run socketIO on another route apart from / ? Any configuration tips to ensure it works correctly?

Hi @BorisOptrx !

I was checking (without much knowledge about socketIO). I was wondering if you explore the namespace configuration as described here? It might be what you are looking for.

If we are not fortunate enough to have community members who can help you, I would also recommend reaching the socketIO community directly.

Hi @David ,
Thanks for your response. I had tried the namespacing/setting the path but wasn’t able to get it to work which is why I thought it best I ask as I am sure someone might have already figured this out. Let me give it another shot and see if I can get it to work, if I do I will post a solution here for others to find should they happen upon this issue in the future.

Appreciate your time.