(Support Team)Docker not supporting arguments

I’m trying to deploy a docker image using “docker run” as a command and “–cap-add SYS_ADMIN --device /dev/fuse” as flags/arguments. At the first deploy it worked but after I redeployed the app stopped working.

According to the following topic, command arguments doesn’t work on koyeb. Is that right? If it is, why it did work the first time I tried?

Commands args works. The thread you shared is focusing on the mechanism to define environment variables that can be interpreted at build and run time.

What you are looking for is the capability to provide the docker args, and we do not support this. You could deploy your service in the privileged mode that you can select in the service configuration instead of --cap-add sys_admin even if it is not exactly the same. You won’t be able to specify --device /dev/fuse to the docker command.

But it worked yesterday.

Is there any way to allow the docker container to access the fuse?

@David the first time I used the command args in koyeb, the flags --cap-add SYS_ADMIN --device /dev/fuse worked. Just when I redeployed it stopped working.